https://linen.dev logo
#plugins-general
Title
# plugins-general
c

clifford_mosley

11/04/2021, 3:22 PM
Hi everyone. New to meltano so sorting through the best "how tos". I'm beginning to use tap-jira against our Jira instance and data is flowing relatively well to a Postgres database. An early issue I'm struggling with is that I can't find the data from issues.fields object persisted anywhere in the database. In meltano.yml, I am exposing issues.* in the select but it seems limited to the schema it knows. What's the right meltano way for expanding this ... something in the meltano select I misconfigured, custom extractor based on tap-jira, integrating my own catalog.json or equivalent in, something else? my current meltano.yml select looks like this ...
Copy code
select:
    - issues.*
    - changelogs.*
    - worklogs.*
    - issue_comments.*
    - projects.projectKeys
    - projects.projectTypeKey
    - projects.roles
    - projects.self
    - projects.simplified
    - projects.url
    - '!*.historyMetadata*'
running a
meltano select tap-jira --list --all
shows that fields should be available ...
Copy code
[selected ] issues.fields
	[selected ] issues.fields.attachment
	[selected ] issues.fields.created
	[selected ] issues.fields.lastViewed
	[selected ] issues.fields.updated
	[selected ] issues.fieldsToInclude
I do in fact see an issues__fields__attachment table in postgres. Has anyone bumped into similar? I've tried limiting the select to only issues.fields and it yields the same behavior. Also tried applying some of the approaches @nick_hamlin and @douwe_maan discussed but was too clueless to fully understand them yet.