https://linen.dev logo
#plugins-general
Title
# plugins-general
j

josh_lloyd

08/16/2021, 7:02 PM
I’m using transferwise’s variant of
tap-mysql
with
LOG_BASED
replication. I’ve got about a dozen meltano pipelines running in a staggered fashion such that at any one time there are no more than 7
elt
pipelines running at a given time. Each of these pipelines is accessing a distinct database on the same AWS RDS MySQL instance. The first time I ran this series of pipelines, most pipelines completely successfully (some errorred for unrelated reasons). The second and third days I ran this series of pipelines most of the pipelines error with the following
Copy code
meltano | Extraction failed (1): pymysql.err.InternalError: (1236, "A slave with the same server_uuid/server_id as this slave has connected to the master; the first event 'mysql-bin-changelog.418935' at 777596, the last event read from '/rdsdbdata/log/binlog/mysql-bin-changelog.418937' at 737078, the last byte read from '/rdsdbdata/log/binlog/mysql-bin-changelog.418937' at 737078.")
So, several were running in parallel at a given time and completed successfully, but most produced some variation of the error above at various points during the extraction. There are several recommendations online for how to solve this, but I’m not sure which one to attempt. Some recommend changing server configuration which may not be possible since I down’t manage these source dbs. Some suggest that the server_id needs to change for each concurrent call, which doesn’t seem to be controllable using this tap and much of the calls seem to be controlled by the state emitted by meltano … any thoughts?