https://linen.dev logo
#singer-tap-development
Title
# singer-tap-development
j

jazzy

05/17/2021, 8:21 PM
Happy to help with the documentation surrounding this: I have developed a tap and it is in its own directory and is built from the cookiecutter template. In another directory I have Meltano installed in its own directory and a different environment. However, I cannot install the custom tap in my Meltano project. I get:
Copy code
- Warning! Plugin 'tap-woocommerce' is not installable.
The extractor in the meltano.yml that was generated using the cookiecutter file looks like :
Copy code
- name: tap-woocommerce
    namespace: tap_woocommerce
    executable: /Users/jazzy/Documents/git/gitlab-work/singer-sdk/tap-woocommerce/tap-woocommerce.sh
    capabilities:
    - state
    - catalog
    - discover
    settings:
    - name: consumer_key
      kind: password
    - name: consumer_secret
      kind: password
    - name: url
    - name: user_agent
    - name: after
    config:
      after: '2021-05-16T08:00:25'
      consumer_key: null
      consumer_secret: null
      url: ''
      user_agent: ''
When using the command:
Copy code
meltano add --custom extractor tap-woocommerce
I get the following prompts: - (namespace) [tap_woocommerce]: - (pip_url) [tap-woocommerce]: The instructions for local directory are: - local directory, in editable/development mode: -e extract/tap-woocommerce - I assumed this would be -e /Users/jazzy/Documents/git/gitlab-work/singer-sdk/tap-woocommerce/tap-woocommerce.sh and have also tried - /Users/jazzy/Documents/git/gitlab-work/singer-sdk/tap-woocommerce/tap-woocommerce.sh - (executable) [tap-woocommerce]: I've tried a few different combinations in each of the prompts but unsure what I need to do to make it installable.